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Installation

ImageJ can be downloaded from https://imagej.net/ij/download.html.* After installation, the program should 

be updated to the latest version with Help>Update ImageJ… (from inside the ImageJ program). This 

replaces the ij.jar file in the ImageJ directory with the latest version and requires that the user has write 

access to the ImageJ directory. If Help>Update ImageJ did not work, take the ij.jar file from 

http://wsr.imagej.net/download/daily-build/ and place it in the ImageJ directory (replace the old one). On 

MacIntosh OS X, you have to right-click the ImageJ icon and select “Show Package Contents”. The  ij.jar

file is in Contents/Resources/Java.

Make sure that ImageJ has enough memory (≈10 GB recommended, but not more than 70% of total RAM). 

Memory is assigned in the Edit>Options>Memory&Threads menu, then restart ImageJ.

The ViPErLEED plugins are available at https://github.com/viperleed/viperleed-imagej and contained in the 

file ViPErLEED_ImageJ_plugins.jar. The most recent version can be downloaded under 

https://github.com/viperleed/viperleed-imagej/releases/latest. This Java archive should be placed into 

ImageJ/plugins or a subdirectory thereof. After restarting ImageJ, a menu entry Plugins>ViPErLEED will 

appear.

Notes for Developers

The file ViPErLEED_ImageJ_plugins.jar is a zip archive and contains the compiled Java .class files, 

a file plugins.config, which determines which commands appear in the ImageJ menus and where. The 

ViPErLEED_ImageJ_plugins.jar file also contains the source code. The source code is also available at 

https://github.com/viperleed/viperleed-imagej.

If you want to modify the plugins, place the source files into a subdirectory of ImageJ/plugins. To avoid 

version conflicts, move the  ViPErLEED_ImageJ_plugins.jar to a place outside ImageJ/plugins 

(alternatively, rename it such that it becomes inactive, i.e., the extension must not be .jar or .zip), and restart 

ImageJ. Now the sources can be compiled from within ImageJ with Plugins>Compile & Run… and used 

essentially the same way as previously the files in ViPErLEED_ImageJ_plugins.jar. After 

Help>Refresh Menus or restarting ImageJ, the compiled plugins will appear in the Plugins menu of ImageJ, 

under a submenu entry with the name of the directory where they reside. Note that the command 

Plugins>Compile & Run… currently does not work with the Fiji distribution of ImageJ; users of Fiji have to 

use the script editor, available via File>New>Script, open the java file and compile with “Run”.

The main classes that are accessible from the ImageJ Plugins menu should have an underscore in the name; 

others are auxiliary classes; these are automatically compiled with the main class. To avoid conflicts with 

other plugins, all classes in the ViPErLEED package contain LEED_ or Leed in the name (the latter for 

auxiliary classes that are not a plugin).

* On macOS 15, after installing ImageJ, the following steps may be required (in a terminal window):
cd to the directory containing your ImageJ.app. Then type
sudo chflags -R nouchg ImageJ.app
sudo xattr -rd com.apple.quarantine ImageJ.app 

https://github.com/viperleed/viperleed-imagej
https://github.com/viperleed/viperleed-imagej/releases/latest
https://github.com/viperleed/viperleed-imagej
http://wsr.imagej.net/download/daily-build/
https://imagej.net/ij/download.html


When modifying the sources and compiling, note that the ImageJ compiler currently only checks for updates 

of the plugin class compiled and classes directly called from the plugin class; it does not recognize 

modifications of an auxiliary class that is called only from another auxiliary class. In such a case, either 

delete the .class file of the modified auxiliary class after modification of its .java file, or compile the 

auxiliary .java file separately, or declare a dummy variable with the uncalled auxiliary class in the plugin, 

to enforce checking for modifications of the sources of this class.

If the newly compiled version works as desired, you can replace the .class files in 

ViPErLEED_ImageJ_plugins.jar with the new version, make this .jar  active again (move it back to 

ImageJ/plugins or rename it back), and delete the individual .class files in your subdirectory of 

ImageJ/plugins. Then restart ImageJ.  When the class files are contained in 

ViPErLEED_ImageJ_plugins.jar, the plugins.config     file   contained in the .jar determines which 

commands appear in the ImageJ menus and where.

Notes on the documentation

Almost all of the documentation text in the following is a copy of the program help, which can be accessed 

via the Help buttons, augmented by several screen shots. You can copy the contents of any help window 

(CTRL-a to select all and CTRL-c1). Paste it into a text editor for printing, annotating, etc. 

Updates of this documentation will be published at https://www.viperleed.org/

License

The code described in this document is licensed under GNU General Public License v3.0 or later (GPL-3.0-

or-later). The authors may decide later to put part of the auxiliary code in this work into the public domain, to

allow incorporation into ImageJ if desired (ImageJ is in the public domain).

This documentation is licensed under the Creative Commons Attribution 4.0 (CC BY 4.0) license.

When using this program (in its original or modified form) for scientific work, please cite the paper 

describing the program [1].

https://creativecommons.org/licenses/by/4.0/
https://www.gnu.org/licenses/gpl-3.0.html
https://www.viperleed.org/
https://imagej.net/ij/plugins/jar-demo.html
https://imagej.net/ij/plugins/jar-demo.html


ViPErLEED Spot Tracker 
This ImageJ plugin is used to extract intensity vs. energy curves [a.k.a. I(V) curves] from low-energy 

electron diffraction (LEED) movies. 

Input Images/Stacks 

Main Input Stack (required)
The movie with the LEED images (must have evenly spaced electron energies, unless intensity vs. 

time or some other data channel at constant energy should be measured). 

Dark Frame and Flat Field (optional) 
These images should be used to correct for the dark current of the camera (and background 

illumination, if any) as well as inhomogeneities of the LEED screen, optics, and camera. The flat field 

is an image (or image stack) of a diffuse diffraction pattern with no spots, only showing the 

inhomogeneities of the optics and camera. The flat field is typically recorded by moving a 

polycrystalline sample holder to the sample position; make sure that the distance from the electron 

source is exactly the same as that of the sample surface. (Since the intensity is spread out over all the 

screen, you may use a higher beam current or longer exposure than for the LEED movie of the 

sample.) A flat field is especially important if the LEED image has a high background intensity, e.g., 

for sample temperatures around or above the Debye temperature of the sample. Dark frame images 

(when present) are subtracted from the input stack and flat field before the flat-field correction. The 

dark frame is best measured with a high negative Wehnelt voltage, suppressing the beam, but keeping 

light emitted by the filament as well as any glow due to (field-emitted) electrons reaching the 
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fluorescent screen.

The formula is

            corrected_pixel_value = (input - dark)/(flat – dark2)

where dark2 is the dark frame for the flat field (usually the same as the dark frame of the main input, 

unless the main input and flat field differ in the exposure time or gain). If a dark frame is not given, 

nothing is subtracted there.

    The (flat - dark2) values must be positive in the area defined by the mask (see below). In case

of negative or zero values (e.g., due to excessive noise), attempts to track (and measure) the LEED 

spots will result in an error message.

    For the dark and flat images, one can provide a stack. If the stack has the same number of images as

the main input, it is used image-by-image for the corresponding main input image. There is no check 

whether the energies are the same as for the main stack; this is your responsibility. Preprocessing of 

these correction image stacks (e.g., averaging over a few energies to reduce noise, 2D fitting or at least

intensity normalization for the flat field) should be selected with Dark & Flat Processing. If the 

number of images of a dark or flat stack differs from that of the main input stack, they are averaged 

and this average is used for all images of the main input. (If the flat is a single image or an average, 

the dark2 also uses the average over the stack, even if it has the same number of images as the main 

input.) The type of dark & flat processing is displayed in abbreviated form next to the Dark & Flat 

Processing button. Some sort of averaging (to reduce the noise) is advisable, especially for the flat 

field.

    Note that image processing with dark and flat requires a mask (see below). The mask defines the 

area where the correction will be performed. Without a proper mask, the correction will result in 

arbitrary values outside the LEED screen; this will prevent proper setting of brightness & contrast and 

may make the LEED screen appear black or dull. 

Mask (required) 
An 8-bit image ("binary image") with white pixels for the background and black for the foreground. 

The foreground area determines the screen area where intensities may be measured. The mask image 

must NOT contain pixel values other than 0 or 255. You can use Analyze>Histogram to see which 

pixel values are present in an image; in the histogram panel click on "Log" (logarithmic y axis scale) 

to see also values that occur for a few pixels only. You can use Image>Adjust>Threshold (and 

"Apply") to ensure that all pixel values are 0 or 255. Images with in-between values cannot be selected

as a mask.

    You have to create the Mask image; start with More>>Create Mask. As soon as a mask has been 

created and selected, it is shown as an outline on the image stack used for spot tracking. Editing of the 

mask image will be reflected by the outline almost immediately. 

All these images or image stacks must be open in ImageJ; you can use More>>Open Images/Movies… on 

the spot tracker to open them (and select them as the input, if appropriate). Alternatively, you can use the 

Plugins>ViPErLEED>Open LEED Movie... command (which can also create a table of metadata when 

opening a movie) or the various ImageJ File>Open and File>Import commands (e.g. File>Import>Image 

Sequence…) for combining multiple images into an image stack (i.e., a movie). Image stacks may be in 



memory or (if the open/import command allows) they can be virtual stacks, i.e., the active image is read 

from disk as required, but not always kept in memory (needs less RAM).

    All these images or stacks must have the same width and height (in pixels). Do not close these images or 

stacks while using the ViPErLEED Spot Tracker. 

Dark & Flat Processing 

If the dark frame and flat field (and the dark2; this is the dark frame subtracted from the flat field) are stacks 

with the same number of slices as the main input stack, one can select several options:

- No averaging: The correction images should be applied slice by slice. In this case, any noise of the 

correction images will increase the noise of the result.

- Average all: Best noise suppression, but no energy dependence (usually not suitable for the flat field).

- Linear fit: This provides good noise suppression, but keeps linear drift with energy or time. This option can 

be useful especially for the dark frames.

- Smoothing: Select this option for averaging over a few energies (usually used for the flat field). The 

Smooth amount determines the noise suppression. (For a smooth amount of n, the noise suppression is 

roughly equivalent to that of averaging over n stack slices, but the algorithm is actually different from 

moving averages, with better suppression of rapid fluctuations and less memory use.) 

Flat field processing type: Before applying the flat field (and

after subtraction of its dark frame, if provided) to the main

image, in most cases further processing of the flat field should be

applied: If the flat field is a stack with 1:1 correspondence to the

input (i.e., same number of slices), one should select at least

normalization, i.e., keeping the average intensity of the stack

(across the mask area) constant. Furthermore, usually the flat-

field intensity decreases towards the edge, because diffuse

scattering intensity from a polycrystalline sample tends to peak at

a scattering angle of 180° (backscattering). Then one should

correct the (background-corrected) flat field by a fit of a 2nd-order or 4th-order polynomial to its logarithm 

(for 2nd-order, this would approximately correspond to division by a best-fit Gaussian; the 4th-order fit is 

usually preferable, but slower to compute). Polynomial fits should be only applied if the long-range intensity 

variations of the flat field are due to the scattering process in obtaining the flat field, not if these variations 

are due inhomogeneous efficiency of the LEED screen or vignetting of the camera.

    One can examine the flat field (after all processing steps) by Show processed flat field. The output of Show

processed flat field can be also used for further processing of the flat field by any image processing method 

of your choice, then the result of this processing can be used as a flat field further on. In this case do not 

forget to deselect the dark frame for the flat field and deactivate the polynomial fit (unless you really want 

it).

Note that processing steps that require all images of an input stack, such as averaging over all images or a 

linear fit over all images of a stack require some computing time. It may take several seconds until the 

processed result becomes available; this may also cause a delay in opening the Spot Tracker main panel 



when it automatically selects the input images or stacks. Expect delays especially if the inputs are supplied as

virtual stacks (i.e., not kept in memory but read from disk on demand). 

Set Energies, I0, t 

The energy range of the input stack, the beam current

I0 (for normalization), and the time (with respect to the

first slice) are usually read from the slice labels of the

main input stack; they are read in when reading the

main image stack. If these data were not available, one

can set them manually, as a linear function or from a

table that has been opened by ImageJ. [Note that one

can open .csv and .tsv files (comma- or tab-

separated values)2 as tables with ImageJ, if they

contain exactly one header line.] The "Set Energies, I0, t" dialog also provides an entry for I00, the offset of 

the beam current I0. I00 can be also read from the I0 values of the dark frame(s) (if present), either using the 

individual values for each energy or a linear fit (if the dark frames are a stack with 1:1 correspondence to the 

main input stack). I00 may be read from the dark frame(s) only if they were obtained without emitted 

electron current (i.e., by setting the Wehnelt voltage to a highly negative value, not by setting the screen 

voltage to 0). If I00 is provided, the actual beam current is calculated as I0 - I00. Usually, the beam 

current should be smoothed; the amount of smoothing can be entered (0 for no smoothing). The amount of 

smoothing is given as the number of points in a moving-averages filter with the same noise suppression; 

actually a modified sinc kernel [2] is used. I0, I00, and the smoothed and I00-corrected beam current are 

plotted after closing this input window if 'Plot I0' is selected. The plot does not include corrections based on 

the background intensity measured during spot tracking (after spot tracking, you can use More>>Plot... for 

this). 

This input window also has an option to set LEEM mode. In LEEM mode, it is assumed that the spots do not

move with energy as they would in normal LEED experiments. 

For experiments with constant electron energy, such as studies of phase transitions (over temperature) or 

evolution over time, one can specify an x axis other than the energy. 

In the Spot Tracker panel, the data present are indicated to the right of the 'Set Energies, I0, t' button; the 

sources of these data are given in square brackets (if not the input stack): [T] table, [!] manual input of a 

linear relationship, [?] kept previous data. For I00, [D] indicates values from the dark frames (lowercase 

[d] if I00 is a linear fit). 

Set Pattern File 

This file describes which beams (spots) are expected and their relative positions in a Cartesian coordinate 

system. This is a comma-separated (csv) file, one line for each diffraction maximum (beam), with the beam 

label, beam h and k indices, Cartesian reciprocal-space coordinates gx, gy, and a beam group index (same for 

equivalent beams). Such a file can be created with the pattern simulator of the ViPErLEED GUI (there, use 

Export from the File Menu). For creating the Spot pattern file in the ViPErLEED GUI, instead of manually 



entering the symmetry, you can also read the symmetry from the experiment-symmetry.ini file created 

when running a LEED I(V) simulation with viperleed.calc. 

Set Indices 

Firstly, an input window appears and asks you to select a stack slice [an energy in usual I(V) measurements] 

where as many spots as possible are clearly visible, including spots near the edge of the screen. Use the slider

below the '..._SpotTracking' image stack to select the energy. (For energy selection, you cannot use one 

of the image stacks supplied as the input, unless it is coupled with the '..._SpotTracking' stack via 

Analyze>Tools>Synchronize Windows). You may use the Auto button of the 

Image>Adjust>Brightness&Contrast panel (B&C; keyboard shortcut CTRL-SHIFT-C1 when the stack is in 

the foreground) or the sliders of the B&C panel to adjust the contrast. If many spots are not recognized (not 

marked by a circle), or many circles do not mark diffraction maxima, you can adjust the noise rejection. Note

that also an improper value of the integration radius may prevent recognition of the spots. Having a few 

'false' spots marked does not hurt as long as these are not close to the position where a diffraction maximum 

would be expected.

When spot indices have been defined previously and fit the maxima, the maxima will be labeled and you can

click 'Labels are OK' if the identification is correct. Otherwise, you have to manually name one or a few 

spots in the next step. 

For naming the spots, a second input window asks you to select a spot by

clicking on it and enter its h, k indices (for superstructures, also fractions

are allowed). The spot must be listed in the pattern file. After pressing Set,

the program tries to name the other spots. Examine the outcome (you may

select the image and press '+' or CTRL-'+'1 to zoom in at the cursor

position). If the spots are named correctly, press OK; otherwise select

another spot and enter its designation (best, choose a spot that has not been

correctly identified).  For LEED patterns recorded with oblique incidence

(> 10° off-normal) it will be necessary to enter several spots. In that case, start with naming a few nearby 

spots. In case of a mistake, you can click on a spot and rename it. As soon as the program has tried to 

identify the spot pattern, the input window also shows the polynomial order it uses to convert reciprocal-

space coordinates to pixel coordinates and the root-mean-square (rms) deviation of the spots from the fit in 

pixels. For small images (e.g., 512 × 512 pixels), the rms deviation should not be much more than about two 

pixels; otherwise carefully check whether the assignment is correct (especially if spots are dense in some 

places, but with larger gaps in between, as it happens for some superstructure cells). Especially in case of 

distorted images, one can also try to adjust the search tolerance (larger values allow for more distortions, but 

are more likely to result in incorrect spot assignment). 

Set Integration Radius 

The integration radius should be selected such that the spots are fully enclosed by a circle with the given 

radius. For low energies, where additional broadening due finite domain and terrace sizes (as well as the 



electron source) may occur, the

integration radius can be given separately

for integer and superstructure spots. 

The output after spot tracking contains a 

plot with the measured spot radii and a

line with half the integration radius as a

function of energy. The point cloud should

be mostly below the line. If there is no

danger of the background area (see below)

overlapping with neighboring spots, and

noise is low, set an integration radius

about 2.5 times the spot radii measured

during spot tracking. (Then the line in the

plot should be at ~1.2 times the typical

values of the point cloud.) Large

integration radii lead to lower noise for

strong spots, but poorer performance for

weak ones (more noise and more errors in 

case of an uneven background). One may use up to 3 times the typical spot radii if (i) the noise of the images

is very low, and (ii) the background due to inelastic scattering is very low and flat, and (iii) all spots are 

bright. Even in case of very close spots and high noise, the radius values should not be less than ~2 times the 

typical spot radii. This means that the line in the spot radii plot should still be above the center of the point 

cloud. Usually it is a good idea to try spot tracking with different radii and compare the I  (  V  )   quality plots   to 

find out which value works best. Keep in mind that the radii must be chosen such that the background area of

each spot does not overlap with any of the neighboring spots. 

Apart from the radius values, there is a selection for the shapes of the

integration area and the background (see the paper about the Spot

Tracker [1]):

- Concentric Circles means that the integration area is a circular disk

and the background intensity is averaged over a circular ring with outer

radius √2 times the radius of the integration circle. This option is best if

spots are very close at high energies, and it also provides the best 

suppression of local variations in the diffuse background intensity due to scattering by phonons.

- Oval background also uses a circular integration disk,

but an elliptical outer border of the background area,

with a semi-major axis twice the radius of the

integration circle and the semi-minor axis equal to that

radius. (The background area has the shape of two large

ears.) This option is best in the case of a background

intensity varying with the distance from the screen

center and it also maximizes the energy range that can

be evaluated for most spots, as the background area does

Example of a Spot Radii plot created when tracking the spots.

The spot radius was set to 12 pixels at the lowest energy (10 eV) and 4 pixels at E → ∞.
At low energies, the point cloud is below the blue line; one might therefore use a smaller 
radius at E = 10 eV. At high energies, the center of the point cloud is above the blue line; 

it is therefore recommended to slightly increase the radius (e.g., to 5 pixels).
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not touch the inner or outer border when the circular background would already touch it. 

- Azimuth blur is for spots blurred in azimuthal (tangential) direction, due to small variations of the azimuthal

orientation of the domains or crystallites. In this case, the integration disk is an ellipse with the semiminor 

axis being the radius defined above. The semimajor axis is oriented in tangential direction [perpendicular to 

the direction to the (0,0) spot] and gets enlarged to fit the azimuthal blur angle entered. For near-circular 

spots [near the (0,0) spot], the background area has a circular outer border, with √2·radius. With increasing 

ellipticity (integration ellipse elongated in tangential direction) the outer background radius remains constant 

as long as the integration ellipse fits inside the circular background outline. Then the background outline 

becomes stretched in tangential direction, i.e., it becomes an ellipse. The total area remains √2 times the 

integration area, thus the background area is about 41% of the integration area. The background intensity is 

measured near the borders in the radial direction from the spot. Thus, the background intensity is sensitive to 

nonlinear background variations over the radius, but insensitive to neighboring spots in the azimuthal 

direction. (This is the opposite to the oval background, where the background is evaluated in tangential 

direction from the spot.)

For both Oval background and Azimuth blur, note that there is no thorough checking for whether the 

background area of a spot overlaps with the integration disk of any of its neighbors. Thus, use these modes 

only if the spots are well-separated up to the highest energy.

The size and type of the integration and background areas are indicated in the top right corner of the 

“SpotTracking” movie.

Track Spots 

Starts spot tracking and intensity measurements (may take up to a minute). Tracking starts at the energy 

where the spot indices have been entered via Set Indices, then the program tries to follow the beams and to 

discover other beams listed in the p  attern   f  ile   if they become visible. 

The numeric values of the parameters determining the tracking process can be usually left at their defaults. 

(When not measuring as a function of energy, the numeric parameters given in 'eV' below rather refer to the 

number of frames, i.e., data points of the output.) 

Noise Rejection (default 2.5): 
Determines how strong a spot must be to be taken

as valid. The value sets the threshold of the

significance (red curve in the p  osition   d  eviatio  n  

plot generated by spot tracking). Increase this value

if spots get trapped by screen inhomogeneities

during tracking or if spot tracking finds spots where

there are none at any energy. If the noise threshold

is too low, stray spots might also wander into

another (real, but weak) spot, inducing deletion of

that spot.



Search beam unseen for (default 10 eV): 
If a beam has not been detected over an energy interval of more than this value, information about its 

deviation from the predicted position is discarded and the program tries to find it as if it had not been 

detected before. 

Energy range for x, y smoothing (default 30 eV): 
Before measuring intensities, the deviations of the spot positions from the predicted value are 

smoothed, to obtain a continuous movement of the integration circle. A larger value of this parameter 

results in smoother movement of the integration circle. In case of local distortions of the LEED 

pattern, a large value may result in inaccurate positions, however. Measurements down to very low 

energies (<30 eV) may require a smaller value for this parameter. This parameter also determines how 

far the position may be extrapolated from the first/last detection of a spot. (Set 'Min. energy range per 

beam', below, to 0 for unlimited extrapolation.) 

Min. energy range per beam (default 30 eV): 
Beams with a total energy range less than this limit are ignored. When this parameter is set to 0 there 

is no such limit, and the program tries to measure all spots in the spot pattern file, irrespective of 

whether they are above the significance threshold. (see 'Noise Rejection', above.) Then, for spots that 

are below the noise threshold at all energies, the positions are inferred from the neighboring stronger 

spots. This is useful, e.g., for checking whether minority areas with a given superstructure are present. 

In this case, check the positions and make sure you don't mistake small background variations for a 

real signal.

Subtract background of bright neighbor spots: 
Since spots often have a long-range background (tails of the spot profile), the background for nearby 

spots is not uniform. Use this option only if the spots show circular symmetry, not for elongated spots. 

This option fits a 1/r² background in the vicinity of bright spots and subtracts that background before 

evaluating the intensity of weaker spots. This option is not available if spot shape 'Azimuth blur' is 

selected. Depending on the spot profiles, for good results, this option may need a larger integration 

radius than the lower limit of twice the measured spot radii. The background-subtracted stack will be 

displayed and can be examined if 'Create debug info' is selected. 

Apply fast background changes to I0: 
This option is only present if the measured beam current I0 is available and I0 smoothing is on, see Set 

Energies, I0, t. It measures the average background intensity and corrects the (processed) beam 

currents based on fast fluctuations of the background intensity. In this context, 'fast' means fluctuations

that would be filtered out by smoothing of I0. This option is useful if the background intensity can be 

determined with less noise than I0. Typically, only fast variations of the background intensity are due 

to I0 variations, slower changes of the background are due to energy-dependent scattering. This option 

works well if the background intensity is high (temperature > Debye temperature), I0 smoothing is not 

much more than 5 eV/ΔE (where ΔE is the energy step), and if dark frames are available, i.e., when 

zero light corresponds to a pixel value of zero. The ViPErLEED hardware measures I0 with very low 

noise; for such data it may be better to disable I0 smoothing in case of I0 jumps instead of using this 

option. To examine whether this option works well, plot the processed I0 vs. (raw) I0 with 

More>>Plot... after spot tracking and check whether the processed I0 is less noisy than the raw I0. You

can also plot the background intensity divided by the (unsmoothed, but I00-corrected) I0. Use the Apply



fast background changes to I0 option only if background/I0 is substantially more noisy (with 

logarithmic y axis) than the background intensity. 

The other parameters in this Spot Tracking Options dialog only affect the quality statistics plot for analysis of

equivalent beams; these options are only available for I(V) measurements, not for, e.g., time-dependent 

measurements. These are the V0i parameter of Pendry's R factor (strictly speaking, its absolute value), the 

smoothing before calculating R factors (default 5 eV), and the energy ranges handled separately (default 100 

eV): I(V) curves are split into regions roughly this size, and for statistics, the R factor between symmetry-

equivalent beams is evaluated for each of these regions. (Splitting into ~100 eV sections is done because the 

intensities of the low- and high-energy regions are often very different; the plot shows mutual R factors vs. 

intensity.)

One can also decide to create only two quick plots (Selected IV Curves and I(V) Quality Statistics) instead of

all plots. For large datasets, this avoids the time-consuming creation of large plot stacks. This is useful if the 

analysis is only meant to check the alignment of the sample, i.e., whether the I(V) curves of equivalent beams

agree, or the impact of different parameter values on the quality of the result. (When saving the data and 

'Save Plots' is selected, the full set of plots will be saved irrespective of the Quick plot only setting.) 

Spot tracking sometimes creates a window named WARNING: Beam(s) uncertain (highlighted). In 

this case, check these beams (marked by thick light blue circles in the main spot-tracker image stack; you 

may have to set an appropriate energy to see them) and use More>>Delete highlighted beams if appropriate. 

This warning may also come up if spot tracking has worked well, but the choice of the energy for Set Indices

did not allow the program to determine a good model for the distortions of the LEED pattern. 

Spot tracking creates several plots: 

Selected I(V) Curves 
If there are symmetry-equivalent beams, a plot of one set of such beams. This is mainly for judging the

alignment and residual electric and magnetic fields. (The selection criteria for this set of curves are a 

large common energy range, a large number of equivalent beams, and high intensity.)

I(V) Curves 
The stack of all I(V) curves extracted. Note that the beam groups are in square brackets; I(V) curves 

belonging to the same group should agree (symmetry-equivalent beams). Negative group numbers 

denote symmetry-forbidden beams; these may have a finite (true or apparent) intensity, e.g., due to 

deviations from perpendicular incidence or an uneven background. 

Spot X/Y Deviations 
For each beam, a plot with the deviations of the measured spot position from the position expected (as 

a function of energy), and this curve after smoothing as defined by the Energy range for x, y 

smoothing parameter. The smoothed deviations are used to obtain the positions of the integration disks

for intensity measurement. Especially if the density of spots is high or there are defects on the screen, 

these plots should be examined to check whether spot tracking has been successful. A large jump or a 

position “running away” from a certain energy on will indicate a problem with tracking. These plots 

also include a line with the 'significance' of the spots, i.e., the value used to determine whether a spot 

is above the noise threshold (below the threshold, the significance is plotted as 0). 



Spot Radii 
A scatter plot with all spot sizes measured, as a function of energy. In case of a superstructure, the 

superstructure spots are marked by different colors than the integer ones. The spots are assumed to be 

ellipses; the extension in radial and tangential direction is plotted. Here, 'radial' refers to the direction 

to the screen center, except for “azimuth blur” mode, where the radial direction is defined as the 

direction to the (0,0) spot. The spot size plotted is an approximation to the standard deviation σ of a 

Gaussian peak. Since the peaks are usually not Gaussians, the sizes depend somewhat on the 

integration radius. The plot also shows a line with half the integration radius; it should trace the center 

of the point cloud or be at larger radius values than the center line of the cloud. Ignore the outliers, 

these are usually very weak spots. In “azimuth blur” mode, the tangential size of the spots is scaled 

down, as if the image was distorted to make the integration ellipses circular. Nevertheless, in “azimuth

blur” mode, this criterion is mainly relevant for the size σ in the radial direction. It is less important in 

the azimuthal direction because the background area does not extend from the ellipse in azimuthal 

direction. See Set Integration Radius. 

I(V) Quality Statistics 
This plot shows the R factors between symmetry-equivalent beams in various ways:

(1) A scatter plot, where the horizontal axis is the average intensity of the I(V) curve or section of that 

curve (normalized to 1000 for the highest intensity occurring anywhere). Typically, due to noise, weak 

beams have higher R factors between symmetry-equivalent beams, i.e., the point cloud is "higher" on 

the left side of the plot. If the experiment was done very well (no residual magnetic fields, sample 

surface exactly normal to the electron beam), the points for the highest intensities will have mutual R 

values of less than 0.1.

(2) A line that shows the R factor against the cumulative energy range of all curve-section pairs with 

an R factor better than the given number. (If there are many symmetry-equivalent beams, this is more 

than the energy range available up to that R factor because many pairs can be selected from one group 

of beams.) Beams where no symmetry-equivalent curves are available are ignored.

(3) If there are beams with negative intensities (after smoothing), the plot shows red triangles: For 

these points, the x axis gives the absolute value of the most negative intensity, and the y axis gives the 

total energy range (per beam) where the intensity is negative. Thus, the red symbols, if any, should be 

as far to the bottom left as possible. 

Markers for regions with negative 
intensity in I(V) curves. Should be 
only at the bottom left.

Symmetry-equivalent pairs with  
mutual RP < 0.1 encompass a total 
energy range of 1.15 × 101 keV. 



Overall X/Y Deviations 
This plot contains information on systematic deviations of the spot positions from the expected 

position. It is based on 2D linear regression of the measured vs. expected position. This fitting 

procedure yields an estimated position of the (0,0) spot (which is usually hidden by the electron 

source). An energy dependence of the (0,0) position can be caused by, e.g., residual (magnetic) fields 

or an off-axis position of the filament in the electron source. The text and arrow at the top right 

indicate the displacement of the (0,0) spot at 100 eV vs. the extrapolated position at infinite energies 

(where the electron beam is not deflected). This calculation assumes magnetic fields, which yield a 

deflection proportional to 1/√E. The direction of the arrow marks the direction of the movement of the 

(0,0) spot in the “SpotTracking” movie with decreasing energy. (This is valid unless the plot window 

is resized, which would distort the plot area and, hence, the arrow.)

    The plot also contains a line for the deviation of the scale factor (with respect to the usual 1/√E 

scale) from 100%. Small scale deviations can be due to the difference of the work functions of the 

filament and that of the sample and its surrounding. There is also a fit line for the scale factor, which 

assumes that deviations are due to such work function differences. For conventional LEED optics 

without additional electric fields, large scale deviations (more than ~2–3% at 50 eV) may indicate 

surface charging. The deviation of the scale factor is usually much larger for MCP-LEED, where 

fringe-field electrodes are present.

Save Data 

Saves the results as csv files in a directory chosen by the user. 

The user can choose a prefix (all file names start with this) and also

select whether to save plots (as created by Track Spots) and the

processed image stack (usually a big file). 

Difference of the (calculated) position of the (0,0) spot between 
100 eV and infinite energy: a measure of residual fields

The deviation in x direction is described by a 
1/√E fit. The reason for the deviation is probably 
a magnetic field.
(For electric fields, the deflection scales with 1/E)

Direction of this difference
on the LEED screen

Scale deviations are 
described by a small 
difference of work functions 
between the filament and 
sample.

Small energy-dependent 
rotation, may be due to a 
magnetic field along the axis

Overall X/Y deviations plot

For an image size of
512 × 512 pixels and near-
normal incidence, the 
change of x and y position 
with energy should not be 
much worse than here.
Otherwise, either the  
magnetic fields are too 
strong or the electron source 
is internally misaligned. 



Files created: 

• The main outcome: The intensities, corrected for the (processed) beam current I0, file 

<prefix>_IVcurves.csv. This file should be processed with the LEED   I  (  V  ) Curve Editor   to 

create the experimental I(V) curves used for comparison with the calculated ones. 

• The uncorrected intensities (not taking I0 into account) are written into _rawInt.csv. For all beams

tracked, also the following information is written as .csv files: The x and y positions (in pixels) as 

well as the raw and smoothed deviations of the positions from the expected ones (_x, _y, _dx_raw, 

_dy_raw, _dx_smooth, _dy_smooth), the significance (set to ≈0 when it is below the noise 

threshold; file _signif), the spot radii in radial and tangential direction (_rSize, _tSize; see Spot

Radii), as well as the intensity in the background region around the integration area and its standard 

deviation (_backgr, _bsigma). 

• A _log.txt file, which contains the parameters used for spot tracking.

• If Save Plots is selected, one file for each of the plots mentioned in the Track Spots   help   is saved. 

• If  Save Stack is selected, the 'spotTracking' image stack is svaed, i.e., the input with dark/flat 

corrections applied and labeled integration circles (a large file). Otherwise, one image with beam-

index designations (spotIndicesImage.tif.zip) is saved (at the energy of Set Indices). The 

image or stack is saved in .tif.zip format. It should be opened in ImageJ without prior unpacking.

More>> Popup Menu 

Open Images/Movies... 
Displays a dialog for opening the input files. Files selected as input that do not fit the requirements 

(e.g., wrong size, or a mask that is not a binary image) will be opened, but not selected as the 

respective input. Opening all files using this command is usually more convenient than opening and 

selecting them individually. If your computer does not have enough RAM for all image stacks 

(including the processed one, after dark-frame and flat-field correction), select "Virtual Stack". Then 

only the images currently required will be read from disk. 

Select stack slice for... 
Asks the user for the energy (or other x-axis variable, e.g., time;

see Set Energies, I0, t) and selects the stack slice (i.e., the

image) for this energy. 

Create mask... 
Facilitates creating a mask for a stack of LEED images. If a flat

field is available, the tool is based on the flat field as an input

(averaging over the stack slices); otherwise it uses the main

input stack (the standard deviation of the intensity vs. energy for

each pixel). There are two sliders: Initially, move the threshold

slider to obtain a smooth outline of the screen area and of the

edge of the electron source (with the arm holding it). In the

second step, you may shrink or grow that area by a few pixels to

refine it. In addition, if the program can guess the outline of the

LEED screen, you can select "Limit to elliptical fit" and you can



try the checkbox to correct for the radius dependence of the intensity, which is typically present in the 

input images. To evaluate the result, you may use Image>Adjust>Brightness&Contrast to better see 

the border of the LEED image in the "SpotTracking" stack. When done, select the mask created in the 

main Spot Tracker panel. If required, use the standard ImageJ selection tools (oval, polygon, freehand)

and the Edit>Fill, Clear and Clear Outside commands to further refine the mask.

Highlight beams... 
Shows the selected beam(s) with a thicker circle. Useful in case of complex superstructures and to 

delete these from the output (see Delete highlighted beams..., below). 

Delete highlighted beams... 
Deletes these beams completely or in a given energy range. These beams will not appear in the output 

of a successive Save Data operation (but they remain circled and named in the stack). One cannot 

undo deletion except by running Track Spots again. 

Un-highlight beams 
Restores normal view after Highlight beams. 

Beam statistics 
Creates a table with one line for each beam successfully tracked: Beam group, number of data points, 

energy of the first and last data point, highest significance, and the energy where the highest 

significance is achieved. There is also a summary line with the total numbers and overall 

minima/maxima.

Plot... 
Creates a plot of various data available. Examples include (processed) I0 or

data for the beam(s) requested, such as intensity. See the list of .csv files in 

Save Data for the items available.

Close plots... 
Closes all or a given subset of plots created by Track Spots. 

Undistort image/stack 
Uses the "Spot Tracking" stack as an input and applies the distortion

corrections determined when the spot indices were set. The undistorted

image has the position of the (0,0) spot at the center. If the outer border of

the LEED screen in the undistorted image is far from elliptical this

indicates that there have not been enough spots close to the border to

correctly determine the distortions. The user can select whether to apply the

correction only to the current slice (the image currently shown) or the 

whole stack. In the latter case, except for LEEM mode, there are two options for the image scale: 

"scale like input" creates a stack where the spots are moving as in the input, while "fixed k-space 

scale" de-magnifies low-energy images such that the spots of a given beam are always at the same 

pixel position. Stack undistortion should be run after spot tracking; then the overall deviations caused 

by residual fields are taken into account. The output can be normalized, by dividing by the processed 

I0 (if available), to eliminate brightness variations due to changes of the incident electron beam 

current. The output of stack undistortion is a virtual stack with caching. Thus, the images are created 

only when needed. This means that the output is quickly visible, but some image operations using the 

https://imagej.net/ij/docs/guide/146-19.html


undistorted output will be initially slow, until all slices of that stack

have been created. This also means that the stack created may

become partly or fully unavailable when one of the input

images/stacks is closed. Note that averaging over the slices of an

undistorted stack (Image>Stacks>Z Project…) requires ImageJ

version 1.54j or later. Further processing of the undistorted stack

(e.g., background subtraction, resizing) requires that you duplicate

this stack.

Averaging over a range of energies of the undistorted stack with

fixed k-space scale is handy to search for weak spots that may be 

hard to detect in individual slices due to modulations by the grid and

noise. One can also create sections through k space with the energy

axis up, using Image>Stacks>Reslice [/]… (see the figure for an example).

List parameters
Creates a table with all numeric parameters; mainly for debugging. When in macro-recording mode 

(Plugins>Macros>Record…), also writes the macro commands for setting all parameter values to the 

Recorder window. 

Read parameters from log file... 
Reads all parameters from a user-selectable file, usually a _log.txt file saved in a previous spot-

tracking session. (Experts might also modify the machine-readable part of such a log file to create a 

setup file; better use a macro for this.) 

Compare parameters with log file... 
Reads all numeric parameters from a user-selectable file, usually a _log.txt file saved in a previous 

spot-tracking session, and compares it with the parameters of the current session (shows a table of 

differences). 

Metadata keywords... 
Defines the names (case-sensitive) of data columns for energy, I0, ... in the input files. Separate 

multiple possibilities with a vertical bar. The keywords should be the full prefix, as it appears below 

the window title in the 'SpotTracking' stack, including the '=' sign. Example: 'energy=|E=|V=' allows

'E=123.5' but not 'Energy=123.5'. 

Reset all options & close 
Resets all options and parameters to their default settings and closes the Spot Tracker. 

Good to Know 

On the main ViPErLEED Spot Tracker panel, red color usually indicates where user interaction is required 

next. 

The Enter key brings the main ImageJ panel to the foreground. When the Spot Tracker panel is in the 

foreground, SHIFT-Enter brings the “SpotTracking” image stack to the foreground. 

In ImageJ, slices are the single images that an image stack (e.g., a movie) consists of. Keyboard shortcuts for

moving to the previous/next slice are ',' or '<', and '.' or '>', respectively. You can also use the mouse wheel. 



Right-click on the animation (play) symbol at the bottom left to change the speed of playing a movie (it may 

be slower than the speed in frames per second, fps, if calculating the frames takes time). 

If you have a movie with strong brightness variations, you may try setting 'Auto contrast stacks' in 

Edit>Options>Appearance…  Bright spots will appear saturated, but you may better see the faint ones. 

Why is there a (V) at the end of title of many image stacks? The (V) stands for virtual stack, i.e., the images

are not in memory but read from disk or calculated on the fly if required. The stack named

..._SpotTracking (created by the ViPErLEED Spot Tracker) is a virtual stack with caching; its slices are 

kept in memory as long as there is sufficient memory. You can click on the status line at the bottom of the 

main ImageJ toolbar to see the used and total memory. Use Edit>Options>Memory&Threads… to change 

the maximum amount of memory allocated to ImageJ (requires restarting ImageJ thereafter; make sure you 

allocate less than the RAM available in your computer). 

If you get an error message saying that all memory has been used, it may help to add

   -XX:SoftRefLRUPolicyMSPerMB=100

to the options for the Java Virtual Machine (JVM). These options are in the ImageJ.cfg file in the ImageJ 

folder. On MacOS, these options are in the info.plist inside the ImageJ package: Right-click on ImageJ 

in the Finder and select Show package contents. The same command with a value of 10 instead of 100 would

be even stronger, telling Java to be very restrictive with memory spent for caches. The downside is that this 

will usually lead to longer execution times.

ImageJ can save images (also image stacks and plots) as .zip files. These are compressed .tif files that 

can be directly opened in ImageJ without unpacking (also by drag&drop onto the status line of the main 

ImageJ panel). I(V) movies recorded as ViPErLEED .zip archives can NOT be opened by the ImageJ 

File>Open command (or drag&drop  on the status line); use Open LEED Movie or More>>Open 

i  mages/movies   for these.

The file types .tif and .zip are the preferred formats for saving, since they contain the full information 

and image resolution. The mask can be also saved as .png file. NEVER save images as .jpg unless they 

are meant for illustration only; even then mind that .jpg has usually very poor quality for sharp borders, 

especially for lines, text, etc.

Single plots (but not stacks of plots) can be modified, e.g., one can zoom into a rectangle selection with the 

'+' key, and reset the range with the gray 'R' appearing under the mouse pointer in the bottom left-corner. 

With the mouse over the left or lower border, there are also other gray symbols; their meaning is explained in

the help text appearing in the status line of the plot when the mouse cursor is above such a symbol.

You can set the default size of plots (and final size of plot stacks) with Edit>Options>Plots…

Many functions of the LEED Spot Tracker can be controlled and automated via the ImageJ macro language. 

Record macro commands with Plugins>Macros>Record…

For smoothing in ViPErLEED, the strength of smoothing is given as the inverse square of the noise gain for 

white noise. E.g., '9 points' means that smoothing will reduce white noise to approximately 1/3 of its original 

value. This corresponds to the noise suppression of a moving average over 9 points. The actual smoothing 

algorithm averages over more points with a weight function. For I0 data and I(V) curves a modified sinc 

smoother [2] is used. 





ViPErLEED I(V) Curve Editor 

Parameters and Settings for the ViPErLEED I(V) Curve Editor 

Initially, the I(V) Curve Editor asks for an input file with the I(V) curves. The following menu determines the

settings.

• V0i: Imaginary part of the inner potential (strictly speaking, its absolute value), needed for 

calculating the R factor. When averaging symmetry-equivalent curves that do not all include the full 

energy range, V0i also determines the width of the transition zone with smooth fade in/fade out. If V0i

is not known, use, e.g., a value of 5 eV. 

• Default energy range to smooth: How much

the curves should be smoothed; this is the

energy range of a moving average with same

noise suppression, typically 0.6 V0i (very good

data or data including low energies < 50 eV) to

1.3 V0i (noisy data). If a previous edit file is

used, this setting has no effect and the value

from the previous session is used. 

• Min. data range per curve: Curves with fewer

contiguous data points than this are ignored.

Note that you cannot make ignored curves (with

too few points) visible any more in the current 

editing session. You have to close and open the Curve Editor to get them back.

• Lowest energy to use and Highest energy to use: The default energy range if a beam is selected for 

the first time. These parameters also limit the range for automatic (noise-dependent) selection of 

energy ranges. The limits do not restrict manual selection in the I(V) curve editor. If a previous edit 

file is used, the settings for the default energy range from the previous session are used, also for 

curves not selected in that session. 

• Select curves/ranges automatically: Automatically selects which groups of symmetry-equivalent 

I(V) curves and which energy ranges will be selected. This selection is mainly based on an estimation

of the noise and its impact on the R factor. 

• Noise limit: Automatic selection is done such that the estimated impact on the R factor is less than 

the noise limit given. Typical values are around 0.05; lower values are more selective, higher values 

lead to a larger total energy range (larger 'database'), at the cost of increased noise. 

• Pattern file: Usually, the information on symmetry-equivalent beams is read from the headings of 

the file with the I(V) curves (spot groups in square brackets). If this is not the case or you want to use

a different symmetry, a spot pattern file can be specified. A spot pattern file is a comma-separated list

(.csv file) of beam names, h, k, gx, gy (reciprocal lattice vector in Cartesian coordinates), and beam 

group number (equal for symmetry-equivalent beams). Such a file can be created with the pattern 

simulator of the ViPErLEED GUI. 



• Previous edit file: If these I(V) data have been edited previously, one may select the file from the 

previous session to continue with the same selection of curves, energy ranges and smoothing. If an 

edit file is selected and you want a fresh start (not continue the session stored in a that edit file), press

the button to open the file dialog and then <Cancel>.

    If Select curves/ranges automatically is checked, automatic selection will supersede the selection 

in the edit file; only the smoothing (and deselection of individual curves from the average) will be 

read from the edit file. 

Commands available with right-clicking
the I(V) Curve Editor buttons

Set Energy Range button

I(V) Curve Selection button 

Help button Prev./Next Group button

Group On/Off button

Smooth Less/More buttons

Options button



Main Plot 

• The main part of the plot area shows the I(V) curve(s) of a group of symmetry-equivalent beams, 

their average (red) and the smoothed average in the selected range (black). 

• The top part of the plot area shows the Y function (modified logarithmic derivative used in Pendry's 

R factor), for the averaged I(V) curve (red) and the smoothed I(V) curve (black). This is the function 

that is compared to the corresponding function of the calculated I(V) curves. 

• Small, colored ticks below the Y function indicate the limits of the data ranges of the individual I(V) 

curves. Thicker and longer ticks indicate an excluded energy range of an input beam. 

Buttons 

• Help ('?' symbol) Shows the help window (this text). Right-click to set or modify a comment 

(annotation) for the current group of symmetry-equivalent beams. (This is indicated by the small 'T' 

symbol.) Comments are saved in the edit file. 

• Save saves the .csv file with the final curves. Right-click to save the data without smoothing. 

• The < and > buttons switch to the previous/next group of symmetry-equivalent beams. Keyboard 

shortcut: '<' or ',' and '>' or '.' (on non-English keyboards, ',' and '.' keys work only if this is the main 

function of the key, without pressing the shift key). The <Page Up>, <Page Down>, <Home>, and 

<End> keys also work. Alternatively, you can use the mouse wheel.

    Right-click the '<' or  '>' symbols for more navigation options: First, last, or last selected beam 

group. You can also jump to the previous or next beam group with a comment, or previous or next 

group with bad agreement of equivalent beams (for the latter, only selected groups and energy ranges

count). You can also enter the beam indices or group number for jumping to a group. 

• Group On/Off selects whether the curves of the currently shown group of symmetry-equivalent 

beams should be used at all. When selecting a group, the energy range is set to the last range selected

(or to the limits, if it was never selected before).

Keyboard shortcut: SPACE bar.

Y function of
Pendry’s R factor

(red: from raw,
averaged data

black: from
smoothed data)

I(V) curves
(red: average

black: smoothed
other colors:

selected beams) Selection rectangle
for energy range

symmetry-equivalent
beams
(can be highlighted,
selected/deselected)

Save
Prev./next group
Group on/off

Options
Smooth less/more

Help (and comments)

Status line (the mouse pointer is at the “smooth more” icon)ImageJ plot controls

Beam group

Set energy range



Right-click to select or deselect all groups. (Note that Select all groups does not select groups where 

the energy span is less than the minimum span.)

    The Auto Select function available via right-clicking does not only switch groups on/off but also 

selects energy ranges, maximizing a figure of merit that depends on the noise.

• Smooth More/Less selects how strongly the curve (or average of curves) will be smoothed. You can 

modify smoothing also with the <ALT> key down and the mouse wheel. Press <SHIFT> for a faster 

change.

    Right-click to change the (default) smoothing for all deselected (switched-off) groups or to apply a

given smoothing value to all selected groups (or the current group and all higher groups). When 

applying the smoothing value, you can select noise-dependent smoothing. This option sets slightly 

stronger smoothing for curves that are more noisy than the currently selected one, and slightly 

weaker smoothing for less noisy curves.

    The Set best smoothing [vs. simulated I(V)] option asks for a file of simulated I(V) curves 

(THEOBEAMS.csv file). It then tries different smoothing parameters to find the smoothing that 

results in the lowest R factor between smoothed experimental and simulated curves, and applies this 

smoothing. This should be done only as the very last step, after refinement of the structure and inner 

potential.

• Set Energy Range (yellow rectangle): Use the ImageJ Rectangle tool from the main ImageJ Toolbar

to select the energy range and then press this button.

Keyboard shortcut: '#' or '0'

    Only the left and right sides of the selection rectangle are taken into account. When the left or 

right side is close to the limit of one of the input curves, and a slight shift of the boundary would 

avoid the necessity to smoothly fade in or fade out that curve, the range snaps to this point. You can 

override the snap with a right-click on the Set Energy Range button and Set energy range to current 

ROI (no snap). 

    For a given beam group, only one energy range can be selected. In other words, you can't have a 

gap in the output data. (This restriction is required by TensErLEED, which is used as a backend for 

LEED-I(V) calculations in viperleed.calc.)

    When there is no selection and the Set Energy Range (yellow rectangle) button is pressed, the 

default energy range is used. This is defined by the limits from the dialog window shown when 

opening the Curve Editor, unless it has been modified by Set energy limits from the context menu of 

the Set Energy Range button. Pressing the Set Energy Range button also selects a curve if it was 

deselected.

    By right-clicking the Set Energy Range button, one can also set the full energy range for the curve 

or the default energy range (as given by the limits). You can also modify these limits (the default 

energy range) or the minimum energy span (previously specified in the starting dialog), and 

optionally restrict the energy ranges of all groups to obey the new limits. Automatic selection of 

beam groups and energy ranges (depending on the noise) is also available from this context menu. 

    Hints for manual selection - Select regions where the Y function at the top of the plot is not too 

noisy. If there is no sufficiently long low-noise range, deselect the whole curve. Rule of thumb: For 

0.5 eV energy steps, in the ideal case, the noise (peak–peak) should be on average less than ~20–

30% of the full vertical range of the Y function. Select the high-energy limit such that high-energy 



regions with an average noise larger than this noise are excluded.

    If symmetry-equivalent beams differ substantially in the low-energy region, exclude these low 

energies. Deviations between symmetry-equivalent beams at low energies only are typically due to 

residual magnetic fields; deviations at all energies are more likely due deviations from normal 

incidence. Very large deviations may indicate that you have the wrong spot pattern file, i.e., the 

symmetry is wrong.

• Options (gearwheel symbol): Use the Options... dialog to change the V0i value (used for calculating 

the Y curves at the top of the plot and for any R factors), to use a fixed x axis with the full energy 

range for all curves, or to show also a noise estimate on the plot (blue). When the noise is plotted, the

y scale for this curve is always fixed (range 0–0.25) and the blue horizontal line is the noise limit for 

automatic selection.

    The Options... dialog also lets you synchronize the current I(V) Curve Editor with the 

'SpotTracking' display of the Spot Tracker: This shows the current energy of the Spot Tracker as a 

black vertical line in the I(V) Curve Editor. The beams of the current beam group in the I(V) Curve 

Editor can be highlighted in the Spot Tracker (unless the highlighted beams of the Spot Tracker still 

mark the dubious beams of spot tracking; these are not modified).

    By right-clicking the 'Options' button, you can select the threshold for classifying 'bad agreement'

of symmetry-equivalent beams and create a list of these 'bad-agreement' beams. A typical value for 

this threshold is between the threshold value for automatic selection and twice that value. 'Bad 

agreement' is based on a 'local R factor' (within a small energy window) between the beam and the 

average of all selected beams. Note that Pendry's R factor is very sensitive at the minima, much less 

sensitive at the maxima. You can see the reason for the disagreement when moving the mouse over 

the button of the beam with 'bad agreement' and comparing its Y function to that of the average. 

    You can also jump to the previous or next group with bad agreement by right-clicking the '<' or '  >  '   

button, respectively; energies of bad agreement are then flagged by thick, vertical lines.

'Bad agreement' is analyzed only for selected beams and energy ranges.

• Individual curve buttons (colored '–' symbols): Press a button to select/deselect the curve of the 

respective beam (if more than one). You can highlight a curve by moving the mouse over the button. 

Then, the status line at the bottom shows the R factor of this beam vs. the average of the currently 

selected beams.

    If a beam has bad data in a given energy range (e.g., due to a dust grain on the LEED screen), 

select that range with the ImageJ rectangle tool (only the left and right side of the rectangle are taken 

into account). Then right-click the button for this beam and exclude this energy range with 'Exclude 

selected energies'. In the plot, the excluded energy range for a single beam is indicated by thick, long

vertical lines below the Y function; then there is a 'Cancel excluded energies' command available 

with right-clicking the button for the respective curve.

Typical workflow 

If you have taken more than one I(V) movie for averaging, average their   I  (  V  ) curves   before using the I(V) 

Curve Editor. 

When opening the (averaged) I(V) curve for the first time, start with automatic selection (also available later

with right-clicking the on/off or Set Energy Range button) to select the energy ranges for all curves. 



Automatic selection is based on an estimate of the noise of the curve and its impact on the R factor. Selection

is done such that the average noise is less than the given noise limit and a figure of merit is optimized. The 

figure of merit increases with selected range and decreases with noise. Typical values for the noise limit are 

around 0.05; lower values are more selective, higher values lead to a larger total energy range (larger 

'database'), at the cost of increased noise. 

The next step is setting the smoothing value. Select a curve that starts at a medium energy and has medium 

noise. Then adjust the smoothing (e.g., using the mouse wheel with the <ALT> key pressed) such that 'real' 

features of the I(V) curves are preserved as best as possible while suppressing the noise. (Noise is often 

visible as wiggles in the smoothed Y curve where the I(V) curves have no apparent wiggles. These wiggles in

the Y curve should be strongly attenuated.)

    Then right-click on a smoothing button and apply the current smoothing to all curves, with 'noise-

dependent smoothing' enabled. Check that the smoothing is not too strong for the first beam groups where 

low energies are included; if so, adjust smoothing for these groups. (Very sharp peaks at low energies mainly 

occur for 5d metals or if very low energies, below 50 eV, are included.) 

Finally, check for bad agreement of symmetry-equivalent beams (CTRL-previous group, CTRL-next 

group1). The energy of the worst agreement of a given beam with the average will be marked by a vertical 

line. You may move the mouse over the button for this beam to compare its Y function with that of the 

average. Sometimes, the bad agreement is caused by a defect of the LEED screen (if only one out of many 

beams is an outlier) and a short section of the 'bad' beam can be excluded: Select the 'bad' energy range and 

exclude it for the beam by right-clicking on its button. In other cases, especially if such a 'bad' region is close

to the ends of the energy range, it makes sense to set the energy range for the beam group such that the 

region of poor agreement is avoided. If many groups show large disagreement of the symmetry-equivalent 

beams, consider repeating the measurement with better adjustment of perpendicular incidence and/or better 

compensation of residual magnetic fields. 

Finally, save the data. You can now use them as input for structure optimization (file EXPBEAMS.csv). 

Towards the end of a LEED I(V) study, when you have a good best-fit model from the simulation 

calculations, you may want to try the 'Set best smoothing [vs. simulated I(V)]' option (right-click one of the 

smoothing buttons) for the last tweak (typically with 'noise-dependent smoothing' enabled). Usually, the 

improvement of the R factor will be marginal. 

Good to know 

Even if you do not save the final result, the Curve Editor keeps track of what you did and saves an 'Edit File' 

in the same directory as the input. If you close the window and open the editor again, it will propose to use 

that Edit File to continue. 

When the mouse is above a button, the status line at the bottom (and the status line of the ImageJ toolbar) 

displays more information.

When the selected curves are averaged, they are first normalized and the slow trends of the intensity between

the beginning and end of the overlap region are equalized. Additionally, if a curve starts or ends inside the 

selected energy range, smooth fade-in or fade-out is used to avoid jumps. 



For zooming into the plot, select a rectangle and press the '+' key.

If the mouse pointer is to the left of the plot area or below it, gray symbols allow you to modify the plot 

limits (axis ranges). The 'R' at the bottom left resets the plot to the original limits, and arrow-like triangles 

near the ends of the axes allow you to shrink or extend the range. The 'F' ('full range, fit all') gets everything 

into the plot window, including energies where no data are available for the current curve(s). You can set a 

fixed energy range corresponding to this full range in the o  ptions  . 

If you want a different color for the selection rectangle, you can set it in ImageJ: Edit>Options>Colors…

You can have more than one I(V) Curve Editor window at the same time, to compare different sets of I(V) 

curves. These windows are synchronized, i.e., they show the same beam group (if available) and the same 

energy range on the x axis. 

Smoothing is performed using a 4th-degree modified sinc smoother [2]. The best smoothing parameter is 

typically 0.6 V0i (very good data or energies < 50 eV) to 1.3 V0i (noisy data). The smoothing parameter 

value (in electronvolts) corresponds to the 'window length' of a moving-average filter with the same noise 

suppression for white noise. (The smoothing algorithm used preserves the shape of the I(V) curves much 

better than a moving-average filter with the same noise suppression.) 

ViPErLEED Utilities
The ViPErLEED Commands window provides a quick way to access the commands. These commands are 

also available via the ImageJ menu Plugins>ViPErLEED or the ImageJ command finder 

(Plugins>Utilities>Find Commands, or type CTRL-L1) 

• Open LEED Movie opens a ViPErLEED movie stored as a .zip file or an 'AIDA' LEED movie 

(Automatic Image and Data Acquisition, EE2000/EE2010; *.vid format). LEED movies are shown 

as Image Stacks in ImageJ. 

• Average I(V) Curves averages the I(V) data of up to six input files.

If you have measured several LEED movies (at different distances to the sample), use this tool for 

averaging the I(V) curves, to reduce the noise (including the noise introduced by the grids). 

Thereafter, use the I(V) Curve Editor. 

• Stitch I(V) Curves joins sets of I(V) curves that have different energy ranges (with a small overlap) 

and possibly different scale factors (e.g., camera gain, exposure time, etc.). 

• I(V) Curve Interpolation interpolates data to different (usually finer3) energy steps. Also works if 

the energy axis has non-equidistant points (may be even descending since plugin version 1.02, but 

must be monotonous).

• R Factor Between Data Sets compares two files with I(V) curves and lists the R factor between 

them for each beam and the overall R factor. (Values obtained with viperleed.calc may be 

slightly different, due to subtle differences of the algorithms.)

• I(V) Curve Quality Statistics provides statistics for assessing the quality of I(V) measurements, 

such as R factors between symmetry-equivalent beams and negative intensities. This tool can create a

list or a plot; the latter is the same as obtained from the Spot Tracker.



• I(V) Curve Tools can modify the intensities in I(V) curve files, extract a subset of the beams or an 

energy range, transform beam indices, and/or modify the information on symmetry-equivalent beams

in I(V) curve files:

• Correct intensity values: Modifies the intensity values. The function for modifiying the intensities

should be specified in the ImageJ macro language. Variables 'I' (current intensity value) and 'E' 

(energy) are provided, and the result should be assigned to the variable 'I'. For simple expressions 

that do not contain '=' signs, 'if' clauses, etc., assignment to 'I' can be omitted, e.g. 'I/sqrt(E)' is 

equivalent to 'I=I/sqrt(E)' and divides all intensities by the square root of the energy.

An energy-dependent correction can be used, e.g., to account for energy-dependent detection 

efficiency of a micro-channel plate in an MCP-LEED system. A typical correction like this might 

be 'Econv=80; I = I/(1-exp(-(E+Econv)/230));' where 'Econv=80' is the conversion 

voltage (the bias at the entrance side of the MCP). Of course, you can also put the value of Econv 

directly into the equation, e.g. 'I/(1-exp(-(E+80)/230));'. 

• Limit energy range: Extracts the given energy range. Specify the energy range as, e.g.,

"80-200". Both limits are included. 

• Extract beams: Extracts only certain beams and omits the others. One can extract only integer 

beams, only superstructure beams, or the beams present (or not present) in a given file [some 

other .csv file with I(V) curves]. 

• Modify basis: Applies a transformation matrix to the spot indices. You can select the new indices 

of the (1,0) and (0,1) spots. You can use this function, e.g., to swap the h and k indices: Change 

(1,0) to (0,1) and (0,1) to (1,0). Swapping h and k is often needed for crystals with threefold 

symmetry, where (1,0) and (0,1) are not equivalent, but it is initially not known which is which.

If the spot labels have included group numbers in square brackets (to indicate the symmetry-

equivalent beams, see below), these group numbers will be deleted. 

• Modify groups of equivalent beams: An I(V) curve file typically contains the group number for 

each beam. The group number is the number in square brackets in the name of the beam given in 

the heading. Beams with the same group number are considered symmetry-equivalent.

These group numbers can be set to the values of a given spot pattern file, changed to a running 

index such that all beams are considered symmetry-inequivalent, or, alternatively, the group 

numbers can be deleted. (In the latter case, any future operations that require knowledge on 

symmetry-equivalent beams will ask for a spot pattern file.) 

You can select one or more of the functions in the above list.

Good to know

If you want to have the ViPErLEED Commands panel present when ImageJ starts, add

 run("LEED Commands");

(with the semicolon) to the "AutoRun" macro of your StartupMacros.txt (or StartupMacros.ijm)  

file (in the ImageJ/macros directory) or to the list of startup commands by selecting Edit>Options>Startup 

from the ImageJ menu. 

http://imagej.net/ij/developer/macro/macros.html
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FAQ

Spot Tracker Input Files

My LEED I(V) movie is a directory of single images, how should I name them?

In principle, it is enough if the energies are equidistant and the file names are sorted in the sequence of 

ascending energy. 

You can then use File>Import>Image Sequence.

In the spot tracker, you can use Set Energies, I0, t to manually set the energy range.

If you want it a bit more comfortable, you can extract the energy from the file name. E.g. if your files are 

named like

20250211_Cu111_E150.5_I01.234_t67.8.tif 

and all energy values are following the “_E” and all sample current values follow the “_I”, you can use the 

spot tracker's More>>Metadata keywords. Have an energy key “_E”. Same thing for beam current “_I”, etc.

In the case of

myCrystal_150.tif

for 150 eV, a simple underscore  “_” would be sufficent as energy key. Also my_crystal_150.tif is ok 

(with version 1.02 of the plugins), but not Cu_111_150.tif, since this would interpret “111” as the energy.

The default list of keys in the spot tracker for the energy is "energy=|E=|V=”, which means that 

“anytextE=150.5moretext” or “blahenergy=150.5blah” etc. will work for decoding the energies. 

Keys are case-sensitive.

Scientific format like “E=1.505e+2” or “E=1.505e02” is not supported; it would be read as “E=1.505”. 

I have color images, what should I do?

For an unclear reason, some OCI LEED systems were sold with a color camera. Since LEED screens emit 

only green light, 50% of the camera's pixels (the red and blue ones) remain essentially dark, so the camera 

sensitivity is reduced to half of what it would be with a monochrome camera.

If you have color images, usually you would use the green channel. (For a 3×8 bit RGB image, use 

Image>Type>RGB stack to see whether there is any useful information in R or B.) 

The following ImageJ macro extracts the green channel from an 8-bit image or stack of 8-bit images:

  setRGBWeights(0, 1, 0);  //green channel has 100% weight 
  run("8-bit");

Note that using 3×8 bit RGB images is not desirable, one should have a better pixel value resolution for good

results, 12 or 16 bits.

Can I use images obtained with a consumer camera (DSLR camera, …)?

NEVER use jpeg images! Apart from the compression losses and the poor 8-bit pixel value resolution, they 

usually have a nonlinear intensity scale (gamma   correction   or an even more complicated function for sRGB).

https://en.wikipedia.org/wiki/SRGB
https://en.wikipedia.org/wiki/Gamma_correction
https://en.wikipedia.org/wiki/Gamma_correction
https://en.wikipedia.org/wiki/JPEG#Typical_use
https://en.wikipedia.org/wiki/Bayer_filter


Note that also other formats such as TIFF from consumer cameras may have a nonlinear relation between 

image intensity and pixel value.

To check whether your camera is linear, take images of the same object with two exposure times that differ 

by a factor of 4. The intensity difference between a bright (but not saturated) and a dark object should also 

scale by the same factor of 4.

Energy Calibration

What accuracy do I need?

For comparison with calculated LEED I(V) curves and structure determination, the accuracy of the energy 

scale should be better than 0.5%, preferably around 0.1%. With most LEED controllers, the factor between 

the 0–10 V input for beam energy control and the actual beam energy is NOT sufficiently accurate. Also 

many handheld digital multimeters are not sufficiently accurate (check the specifications).  The ViPErLEED 

hardware contains a high-voltage input for accurately measuring the filament voltage, used to calibrate the 

energy scale. If your LEED controller has no output for the filament high voltage, see the documentation of 

the  ViPErLEED data acquisition system for how to access the filament voltage.

Do not care about a small offset between nominal and actual beam energy (up to a few eV); LEED I(V) 

calculations will shift the energy axis if necessary.

My LEED controller has a nonlinear relationship between nominal and actual 
electron energy. What should I do?

The spot tracker also works if the energies are not evenly spaced (they must be ascending, however).

If you can determine the real filament voltage (e.g. by measuring the filament high voltage during the 

acquisition of the LEED movie4), it can be used as an input for the spot tracker. You can open a table (.csv 

or .tsv file2) with the actual beam energies in ImageJ and then select it with Set Energies, I0, t. The table 

must have one line for each image of the movie. If the true energies are available from the metadata of the 

LEED movie (shown in the status line at the top of the image stack, e.g. “Emeas=150.5”) you can use the 

spot tracker’s More>>Metadata keywords to define this as an energy key (in the case above, the key should 

be “Emeas=”). Then you can select “input stack” as a source from where to read the energies in “Set 

Energies, I0, t”.

The I(V) curve editor needs equidistant energies. Interpolate the I(V) curves obtained from the spot tracker to 

equidistant energies using the I(V) curve interpolation utility. For interpolation, select an energy step that is 

not larger than the smallest step in the input file.3

Beam Current I0

Do I need a measurement of I0, and if so, why and how?

The current I0 of the electron beam incident on the sample is used to normalize the intensities. For most 

LEED controllers (not for OCI controllers if configured to keep I0 constant), I0 depends on the electron 

energy. In addition, especially during warm-up, sudden jumps of the beam current occur due to stick-slip 



motion inside the electron source. Note that the emission current displayed by many LEED controllers is not 

the same as I0; the emission current is the total current emitted by the filament and also includes electrons 

that impinge on electrodes inside the electron source (e.g., the anode). Thus, the emission current is usually 

substantially higher than the beam current I0.

If there are slow and smooth variations of  I0 over energy or time, it is not absolutely necessary to correct for 

changes of I0 when the I(V) curves are used for LEED I(V) calculations. Pendry’s R factor is insensitive to 

slow and smooth variations of a scale factor of the intensity. If the experimental intensities are not corrected 

for changes of I0, substantial variations of I0 may lead to a visually poor agreement between the measured 

and calculated I(V) curves, however.

If the LEED controller does not keep I0 constant and provides no means to measure I0, during the I(V) data 

acquisition, the ViPErLEED data acquisition system can measure the sample current with the sample biased 

to +33 V. The bias voltage is needed to suppress emission of secondary electrons, which would lead to an 

incorrect current determination. (Without sample bias the sample current can be negative or positive, 

depending on the secondary electron yield δ. Typically, the measured sample current of an unbiased sample 

would be even zero at some energy where δ = 1.) When measuring the current of the biased sample, one 

would typically run the I0 measurement before or after acquisition of the LEED I(V) movie, but with the 

same energy range and steps. Then, the table with the I0 values (.csv or .tsv file2) should be opened in 

ImageJ, and this table and the column with the actual beam energies should be selected in Set Energies, I0, t. 

Measuring I0 before or after the acquisition of the LEED I(V) movie won’t help in case of unreproducible 

jumps of I0. If this happens, the effect of such jumps can be mitigated by the Apply fast background changes 

to I0 option of Track Spots.



Footnotes

1 On macOS, you use the  ⌘ key instead of CTRL.

2 Comma-separated values or tab-separated values. The decimal separator must be a period, not a comma, and the 
value separator in .csv files must be a comma, not a semicolon.

3 The interpolation utility does no averaging if steps of the input file are closer than the output steps. Thus, if the 
output steps are too large, information will be lost, leading to an unnecessary increase of the noise.
For a similar reason, the input steps should be at least locally roughly equidistant, otherwise widely-spaced data 
points get more weight than narrowly spaced points. This would be undesirable when considering noise of the data.

4 Note that the current drawn by the high voltage measurement is typically much higher than the beam current. Thus, 
when measuring the filament voltage, you cannot measure the beam current I0 at the same time.


